You can use any of the main browsers in order to use Logitude in HTML5 version:

  • Chrome(2 latest version)
  • Firefox(2 latest version)
  •  Opera(2 latest version)

Coming soon : Safari

Recent Posts